NetRegistry Phone Support Interruption
Incident Report for Webcentral Service Status
Resolved
Our phones lines have now been restored.
Posted Jan 27, 2017 - 12:00 AEDT
Update
Correction to the prior update, customers are advised to call 1300 638 734 to contact our support team as we are still experiencing issues with our other numbers. Live chat and email are still both operational
Posted Jan 26, 2017 - 10:36 AEDT
Monitoring
We have resolved the issue causing inbound calls to fail, customers are now able to call our support and sales lines. We are still investigating a problem preventing us from making outbound calls. We will continue to update this alert until the issue is resolved.
Posted Jan 25, 2017 - 23:37 AEDT
Investigating
We wish to advise our customers we are currently experiencing technical difficulties with our phone support system. Our platform engineers are currently investigating this as a high priority.

Customers requiring support can still use our live-chat and email services to contact us.

Thank you for your patience while we address this interruption.
Posted Jan 25, 2017 - 15:38 AEDT
This incident affected: Support Center (Web/Email Support Enquires).