cPanel Email Delivery Issue (Microsoft)
Incident Report for Netregistry Status Page
Update
We would like to advise that the following cPanel servers have also been removed from Microsoft's blocklist and customers that are hosted on these servers will be able to send to Hotmail and Live users.

cp393.ezyreg.com
cp377.ezyreg.com
cp223.ezyreg.com
cp368.ezyreg.com
cp319.ezyreg.com
cp178.ezyreg.com
cp217.ezyreg.com
cp225.ezyreg.com
cp233.ezyreg.com
cp240.ezyreg.com
cp242.ezyreg.com
cp259.ezyreg.com
cp262.ezyreg.com
cp357.ezyreg.com
cp358.ezyreg.com
cp383.ezyreg.com
cp389.ezyreg.com
cp398.ezyreg.com
cp147.ezyreg.com
cp152.ezyreg.com
cp219.ezyreg.com
cp267.ezyreg.com
cp324.ezyreg.com
cp326.ezyreg.com
cp338.ezyreg.com
cp339.ezyreg.com

We will provide further updates once they become available.
Posted 15 days ago. Apr 06, 2018 - 10:29 AEST
Update
We would like to advise that the following cPanel servers have been removed from Microsoft's blocklist and customers that are hosted on these servers will be able to send to Hotmail and Live users.

cp38.ezyreg.com
cp202.ezyreg.com
cp204.ezyreg.com
cp208.ezyreg.com
cp212.ezyreg.com
cp222.ezyreg.com
cp224.ezyreg.com
cp226.ezyreg.com
cp228.ezyreg.com
cp230.ezyreg.com
cp333.ezyreg.com
cp235.ezyreg.com
cp236.ezyreg.com
cp237.ezyreg.com
cp245.ezyreg.com
cp246.ezyreg.com
cp248.ezyreg.com
cp256.ezyreg.com
cp257.ezyreg.com
cp258.ezyreg.com
cp260.ezyreg.com
cp264.ezyreg.com
cp266.ezyreg.com
cp269.ezyreg.com
cp273.ezyreg.com
cp323.ezyreg.com
cp333.ezyreg.com
cp344.ezyreg.com
cp351.ezyreg.com
cp359.ezyreg.com
cp362.ezyreg.com
cp365.ezyreg.com
cp366.ezyreg.com
cp369.ezyreg.com
cp373.ezyreg.com
cp374.ezyreg.com
cp375.ezyreg.com
cp376.ezyreg.com
cp378.ezyreg.com
cp387.ezyreg.com
cp390.ezyreg.com
cp392.ezyreg.com
cp396.ezyreg.com
cp546.ezyreg.com
cp325.ezyreg.com
cp391.ezyreg.com
cp206.ezyreg.com

We will provide further updates once they become available.
Posted 18 days ago. Apr 03, 2018 - 11:16 AEST
Identified
We would like to advise that we have identified the delivery issue and are currently working on a resolution. We will provide further updates once they become available.
Posted 23 days ago. Mar 29, 2018 - 09:22 AEDT
Investigating
We would like to advise customers that are hosted on our cPanel servers will be experiencing email delivery issues to recipients managed by Microsoft (hotmail, live, etc). Our technicians are aware and are currently working on this as a priority, more updates to come.
Posted 26 days ago. Mar 26, 2018 - 10:35 AEDT
This incident affects: cPanel Hosting (cPanel Email Services).