Service Disruption - Power outage.
Incident Report for Webcentral Service Status
Resolved
Power was restored.
Posted Jan 11, 2017 - 19:25 AEDT
Investigating
Netregistry wishes to advise our valued customers that there is currently a power outage in the building of our level 2 support centre. Due to this, we currently have reduced support capacity.

Thank you for your patience while we work to restore full service.
Posted Jan 11, 2017 - 14:57 AEDT
This incident affected: Support Center (Live Chat, Web/Email Support Enquires).