Domain Search Functionality
Incident Report for Netregistry Status Page
Resolved
The domain search functionality on our website has now been restored.
Posted about 2 months ago. May 09, 2017 - 14:37 AEST
Investigating
We would like to advise that the domain search functionality on our website is currently not operational. We suggest any customers that wish to purchase a domain name to contact our sales team in the meantime.

We will post a further update once available.
Posted about 2 months ago. May 09, 2017 - 11:19 AEST
This incident affected: Netregistry Console (Domain Name Management).