Domain Management Issues
Incident Report for Netregistry Status Page
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 10:20 AEDT
Monitoring
Thank you for your patience while we've work to resolve this issue. Customers can again manage their domains through the Console.

The connection to the registry, which is used to manage domains, has been restored and our Technicians are monitoring this to ensure there are no further problems.
Posted Feb 20, 2021 - 10:18 AEDT
Identified
We are currently experiencing connection issues to the Tucows HRS registry.

Affected customers are unable to manage their domains through the Console.

Our Technicians are investigating this with the utmost urgency and we will keep our customers updated as we work to resolve this.
Posted Feb 19, 2021 - 18:17 AEDT
This incident affected: Netregistry Console (Domain Name Management).