Website Outage
Incident Report for Netregistry Status Page
Resolved
At this stage we believe the access issue has been resolved. Customers websites and ours are back up and able to be accessed.
Posted 5 days ago. Nov 15, 2017 - 11:51 AEDT
Update
Customers are reporting difficulty accessing the Netregistry website, console and their own websites from non-mobile connections within Australia. International and mobile access appears unaffected.

We are investigating the issue as a priority with other ISPs to determine the source of the issue.
Posted 5 days ago. Nov 15, 2017 - 09:34 AEDT
Investigating
Customers are reporting difficulty accessing the Netregistry website, console and their own websites from non-mobile connections within Australia. International and mobile access appears unaffected.

We are investigating the issue as a priority.
Posted 5 days ago. Nov 15, 2017 - 09:17 AEDT
This incident affected: Netregistry Console (Domain Name Management, Control Panel) and DNS (National).