Help Desk Degradation
Incident Report for Netregistry Status Page
Resolved
This issue has now been resolved.
Posted about 1 month ago. Mar 27, 2019 - 10:42 AEDT
Investigating
We would like to advise that we are currently experiencing intermittent technical difficulties with our phone and live chat systems. Our technicians are working to have this resolved as soon as possible.

Customers may experience longer than normal wait times on our phone and live chat channels.

We apologise for the inconvenience this may cause.
Posted about 1 month ago. Mar 26, 2019 - 14:50 AEDT
This incident affected: Netregistry Support Center (Live Chat, Help Desk).