Website Checkout Disruption
Incident Report for Webcentral Service Status
Resolved
Our team have put a fix in place and have not noticed any re-occurrence of the problem. If you notice any issues as you're checking out, please call 1300 638 734 or submit an enquiry directly to our sales team here; https://www.netregistry.com.au/forms/sales-enquiry/
Posted Jul 27, 2020 - 16:39 AEST
Monitoring
Our team have put a fix in place and are continuing to monitor the checkout process to make sure the problem doesn't re-occur. If you notice any issues as you're checking out, please call 1300 638 734 or submit an enquiry directly to our sales team here; https://www.netregistry.com.au/forms/sales-enquiry/
Posted Jul 27, 2020 - 12:52 AEST
Investigating
We would like to advise customers on the current intermittent error during the checkout process on the Netregistry website that is currently preventing our customers from completing purchases.

We are currently investigating the matter and will continue to provide updates as soon as possible.

Please call 1300 638 734 or submit an enquiry directly to our sales team via the link if you are experiencing issues https://www.netregistry.com.au/forms/sales-enquiry/
Posted Jul 27, 2020 - 11:27 AEST
This incident affected: Webcentral Infrastructure (Billing Systems).