DNS Issues
Incident Report for Webcentral Service Status
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 11:25 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2020 - 13:42 AEDT
Investigating
We're currently experiencing problems with the Netregistry Name Server. Customers using Cloud name servers are experiencing DNS propagation issues (i.e. A, MX, CNAME, etc. records not loading, editing or deleting).

Our Technicians are working to get this operational with a matter of urgency. Thank you for your patience and understanding, we will keep you updated with our progress.
Posted Oct 17, 2020 - 17:33 AEDT
This incident affected: Website & Email Hosting (VPS Hosting) and Domain (Domain Name Management).