Phone System Service Disruption
Incident Report for Netregistry Status Page
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 12:56 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2020 - 21:29 AEST
Investigating
We are currently experiencing issues with our phone system.

Our technicians are looking into this as a priority. Live chat and email support are unaffected by this issue, although wait times may be longer than usual.

We apologise for any inconvenience this incident may cause you.
Posted Jul 20, 2020 - 20:46 AEST
This incident affected: Netregistry Support Center (Help Desk).