Purchasing SSL Certificate Issue
Incident Report for Webcentral Service Status
Resolved
We have monitored this issue and will now mark this as resolved.

If you need to contact our Sales team you can do so by calling 1300 638 734, or if you need to contact our helpful Support team you can do so by calling (02) 9934 0501.
Posted Aug 14, 2020 - 09:22 AEST
Monitoring
A fix has been implemented and we will continue to monitor this issue to ensure that it is resolved appropriately.

Customers wanting to purchase an SSL Certificate will now be able to do so.

If you need to contact our Sales team you can do so by calling 1300 638 734, or if you need to contact our helpful Support team you can do so by calling (02) 9934 0501.
Posted Jul 31, 2020 - 14:37 AEST
Investigating
Customers are currently unable to purchase SSL Certificates through our website.

We are currently investigating the matter and will continue to provide updates as soon as possible.

If you need to contact our Sales team you can do so by calling 1300 638 734, or if you need to contact our helpful Support team you can do so by calling (02) 9934 0501.
Posted Jul 31, 2020 - 10:15 AEST