Netregistry Website Emergency Maintenance
Incident Report for Netregistry Status Page
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 17:28 AEST
Monitoring
Thank you for your patience while our technicians have worked on the Netregistry website issue. Customers can now access the Netregistry website.

We will continue monitoring this over the next 24 hours to ensure the issue is completely resolved.
Posted Jul 29, 2020 - 17:19 AEST
Update
The Netregistry website is currently down due to an urgent fix identified by our engineers. You can still login to your account by visiting https://theconsole.netregistry.com.au/ directly.

If you need to contact our Sales team you can do so by calling 1300 638 734, or if you need to contact our helpful Support team you can do so by calling (02) 9934 0501. We expect that the website will be back up in less than 1 hour.
Posted Jul 29, 2020 - 17:08 AEST
Identified
The Netregistry website is currently down due to an urgent fix identified by our engineers. You can still login to your account by visiting https://theconsole.netregistry.com.au/ directly.

If you need to contact our Sales team you can do so by calling 1300 638 734, or if you need to contact our helpful Support team you can do so by calling (02) 9934 0501. We expect that the website will be back up in less than 1 hour.
Posted Jul 29, 2020 - 17:05 AEST
This incident affected: Netregistry Support Center (Live Chat) and Network Infrastructure (External Network).