Cloud webmail disruption
Incident Report for Netregistry Status Page
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 14, 2019 - 11:52 AEST
Monitoring
We have resolved the cloud email issue, and customers are now able to log in again. We will continue to monitor the status of these services.

We appreciate your patience.
Posted 4 months ago. Apr 12, 2019 - 18:32 AEST
Investigating
We are currently investigating an issue affecting customers with cloud email services, whereby they are unable to access webmail. This issue is being investigated as a priority and updates will be posted as they are available.

We appreciate your patience.
Posted 4 months ago. Apr 12, 2019 - 15:54 AEST
This incident affected: Cloud Hosting (Cloud Email Services).