Cloud Webmail Issues
Incident Report for Webcentral Service Status
Resolved
Thank you for your patience while our technicians have worked to identify and resolve the Cloud Webmail Issues.

All Cloud Webmail issues have been resolved and customers will be able to login through the Online Webmail Portal.
Posted Jul 24, 2020 - 11:05 AEST
Investigating
We would like to inform customers of Cloud Webmail issues that we are currently experiencing.

Customers affected by this will not be able to access the Online Webmail Portal. We advise customers to use an email client over this period to send, receive and view their emails. If you need assistance with this you can view our Setting up Cloud Email Support Article (https://support.netregistry.com.au/s/article/Email-setup-tutorial) or contact our Support Representatives via Phone, Email or LiveChat.

We appreciate your patience while our technicians work to resolve this as fast as possible.
Posted Jul 24, 2020 - 09:40 AEST
This incident affected: Website & Email Hosting (WordPress Hosting).