Global Salesforce Outage - No impact to Core Services
Incident Report for Netregistry Status Page
Resolved
This incident has been resolved.
Posted May 12, 2021 - 14:25 AEST
Identified
Due to a Global Salesforce outage, our support form and LiveChat service is currently not operational. Please contact us via our Phone on 1800 194 952 for any urgent issues.
Posted May 12, 2021 - 09:58 AEST
This incident affected: Netregistry Support Center (Live Chat, Help Desk).