Console Service Disruption
Incident Report for Netregistry Status Page
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 19:58 AEST
Identified
We would like to advise customers that we are currently experiencing some issues with our customer facing console as of 12:30pm. Customers may experience slow responsiveness from their console or the inability to log in.

We are investigating this as a priority and will post updates as they are available.
Posted Jul 20, 2020 - 14:56 AEST
This incident affected: Netregistry Console (Control Panel).