Cloud Webmail - Not Able To Load Inbox
Incident Report for Webcentral Service Status
Resolved
Our engineers have closely been monitoring this incident over the past 24 hours and can confirm that this has now been resolved.
Posted May 11, 2017 - 13:37 AEST
Monitoring
We believe the issue has now been resolved and are monitoring this closely. If you are still experiencing difficulty, you may need to close and re-open your internet browser or refresh the page.
Posted May 10, 2017 - 11:01 AEST
Investigating
We would like to advise that we are experiencing service interruptions to a segment of cloud hosted email customers. This is causing some users that are logged into Webmail to not be able to view their inbox. Other users are experiencing difficulty logging into the webmail interface.

Our engineers are currently working on this issue to restore services back to normal.

An update will be posted once available.
Posted May 10, 2017 - 09:28 AEST
This incident affected: Website & Email Hosting (WordPress Hosting).