Console Disruption
Incident Report for Netregistry Status Page
Resolved
We are now confident the issue has been repaired. We thank you for your patience.
Posted 7 months ago. May 16, 2017 - 17:18 AEST
Investigating
We would like to advise customers of a disruption causing The Console to be inaccessible at this time. Our administrators are investigating this as a priority and updates will provided as they are made available. Customers may experience longer than expected wait times when contacting our support team.

Customers will be unable to login, manage and order domains and services via the Console at at this time.
Posted 7 months ago. May 16, 2017 - 14:15 AEST
This incident affected: Netregistry Console (Domain Name Management).