Domain Management Interruption
Incident Report for Netregistry Status Page
Resolved
We would like to advise our customers that this issue has since been resolved at approximately 2pm AEDT.
Posted 12 days ago. Feb 13, 2017 - 17:26 AEDT
Identified
Customers are advised that we are currently experiencing a disruption when attempts are made to register or renew some domain name extensions. In addition, some domain information may be unavailable via your Console account / reseller portal.

Our system engineers are working to restore service as a priority. We do apologise for any inconvenience caused.
Posted 12 days ago. Feb 13, 2017 - 13:21 AEDT
This incident affected: Netregistry Console (Domain Name Management, Control Panel).