Domain Management Interruption - .ORG
Incident Report for Netregistry Status Page
Resolved
We would like to advise that the functionality of a small subset of .org domain names has now been restored, however if you still are experiencing difficulties please contact our support team.
Posted 28 days ago. Jun 01, 2017 - 14:58 AEST
Identified
There is a technical issue currently preventing customers the ability to renew, modify and/or manage a small percentage of .org domains.

We are currently working with our registry provider in order to have the problem resolved.

We appreciate your patience and understanding during this period.
Posted about 1 month ago. May 18, 2017 - 15:16 AEST