Service Disruption - .au Domain Registration and Renewal
Incident Report for Netregistry Status Page
Resolved
This matter has now been resolved and domains are now registering/renewing normally.
Posted 7 months ago. May 31, 2018 - 16:26 AEST
Investigating
We wish to advise that we are currently experiencing difficulty registering and renewing .au domain names for some customers. We are working with the registry to restore this functionality as soon as possible. More updates will be provided as progress develops.

We apologise for any inconvenience this may cause and thank you for your patience while we have this addressed.
Posted 7 months ago. May 31, 2018 - 16:08 AEST
This incident affected: Netregistry Console (Domain Name Management).