Payment Gateway - Service Interruption
Incident Report for Netregistry Status Page
Resolved
This incident has now been resolved.
Posted 5 months ago. Nov 17, 2018 - 20:38 AEDT
Investigating
We are currently experiencing technical difficulties with our payment gateway services. This is currently preventing customers from processing payments. Our system administrators are currently investigating and working to resolve this issue as a priority.

We will update this service alert as more information becomes available.
Posted 5 months ago. Nov 17, 2018 - 16:05 AEDT
This incident affected: Netregistry Console (Domain Name Management, Control Panel) and Network Infrastructure (Internal Network).