Phone System Degradation
Incident Report for Netregistry Status Page
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 23, 2018 - 16:56 AEDT
Monitoring
The degradation with our phone systems has now been resolved however we will continue to monitor this closely to prevent this from re-occurring.

We thank you for your patience during this period.
Posted about 1 month ago. Oct 23, 2018 - 15:17 AEDT
Investigating
We would like to advise customers that we are currently experiencing degradation with our phone system, which may result in poor call quality or disconnections. We recommend during this period that customers contact us via our Live chat and support email.

Updates will be provided as they are made available.
Posted about 1 month ago. Oct 23, 2018 - 13:02 AEDT
This incident affected: Netregistry Support Center (Help Desk).