Cloud Email SSL Certificate Issues
Incident Report for Netregistry Status Page
Resolved
This incident has been resolved.
Posted May 14, 2020 - 15:16 AEST
Monitoring
We would like to inform customers on our Cloud Email services of issues they may be facing due to the email certificate being renewed. This enables customers to continue sending emails with the appropriate security.

We have noticed that customers using Apple products are experiencing issues after this change.

If you are an Cloud Email customer using Apple products, the attached guide will assist you in resolving these issues : https://support.netregistry.com.au/articles/nr/Apple-Mail-Verification-Issue-23-04-2020/
Posted Apr 23, 2020 - 16:26 AEST
Identified
We would like to inform customers experiencing any SSL Certificate issues with Cloud Emails that you will need to update your email settings to "Accept", "OK" or "Trust" the renewed email certificate.

The email certificate has been renewed so that you can continue sending all your emails with the appropriate security you need. Once customers have updated this you will be able to continue sending emails as normal.

We will provide any further information to assist with this as it becomes available.
Posted Apr 23, 2020 - 12:35 AEST
This incident affected: Cloud Hosting (Cloud Email Services).